1. Overview and Essential Concepts

NotAQuad is software for computer-assisted georeferencing of scanned maps. It uses pattern search and self-learning as substitutes for manual aspects of traditional georeferencing tools. The program can handle arbitrary map layout, scale and coordinate system. [This distinguishes NotAQuad from a companion program, Quad-G+, which was designed for large-scale quadrangle maps.] NotAQuad is particularly well-suited for georeferencing a group of maps having the same base as often found in atlases. The underlying theory and algorithms of both programs are discussed in a related paper [CAGIS, 2018, submitted] and are not repeated here.

NotAQuad's only assumption is that the map contains a drawn graticule in the area to be georeferenced. Graticule intersections serve as ground control points (GCPs) with known geographic and image coordinates. If known, the map projection can be supplied as input. If not, the user can choose from a list of a list of candidate projections and the program will evaluate each in terms of its agreement with the GCPs.

NotAQuad produces georeferenced map images and text files with georeferencing information. Various options are provided for compression, overviews, and image format.

1.1 Pattern Matching

Instead of asking users to digitize a GCP graticule intersection, NotAQuad attempts to find the intersection by searching for a defined pattern in the image. There are 9 defined patterns with these basic shapes:
Figure 1. Graticule intersection patterns for GCPs.

The “+” pattern corresponds to the interior of a graticule grid, whereas the others represent perimeter marks. Notice that each pattern consists of 2, 3, or 4 ticks. The tick length is under user control, as is the pattern color. Most importantly, the angle of tick intersections adapts to the map projection and location within the graticule. The basic idea is that given the type of mark and a rough location, NotAQuad can find the precise location within the image by searching for the mark pattern. The “rough location” is found in one of three ways. If a user enters a lon/lat value for a GCP, the program computes the rough image coordinates using the nearest GCPs to construct a linear model of relationship between geographic and image coordinates. Alternatively, whenever NotAQuad computes a lon/lat value, the corresponding \((u,v)\) is estimated using the same approach. Finally, a user may digitize a rough location in the image.

It should be mentioned that a user does not have to accept the result of pattern-matching; marks may be positioned manually by dragging or using keyboard arrows.

1.2 Minimizing Data Entry

Lon/lat values for GCPs need to be specified precisely, which is obviously tedious whether using decimal degrees or degrees-minutes-seconds. To avoid this, NotAQuad generates lon/lat values whenever a new GCP location is digitized. In particular, another local model is used to estimate lon/lat for the new GCP. These coordinates are then adjusted to match those of the nearest graticule intersection. Obviously, all graticule intersections can be computed without error from the graticule spacing and origin. Note that the local model need not be highly accurate because graticule meshes are always coarsely spaced. A model needs only to correctly identify the closest intersection. These models are built on the fly as points are added to the collection of GCPs.

Data entry is also minimized by a “make grid” facility. This allows one to create regularly spaced GCPs at arbitrary intervals in longitude and latitude. Thus by using the map graticule spacing, one can generate new intersection GCPs with exact lon/lat values and approximate image coordinates. Pattern search can then be used for exact positioning.

1.3 Spatial Coordinate Systems, Transformations, and Errors

Some understanding of geospatial coordinates and modeling is necessary to interpret NotAQuad’s error measures and other program aspects. Let \((\phi, \lambda)\) be a (longitude, latitude) pair. Many lon/lat systems exist, known as datums. Thus strictly speaking \((\phi, \lambda)\) has no meaning unless tied to a datum, and NotAQuad requires that one be specified for every map. Typically a map’s datum is provided as part of the legend or in other marginalia. Knowing the correct datum is particularly important for large-scale maps (scales of 1:500000 and greater). A drop-down menu offers the four most commonly used datums along with hundreds of other well-defined geographic coordinate systems.

Given some map projection \(P\), we have \((x,y) = P(\phi, \lambda)\), where \((x,y)\) are Cartesian projected coordinates with \(x\) increasing to the right and \(y\) increasing upward on the map page. Along with the datum, the projection must always be specified when using NotAQuad. Image coordinates \((u,v)\) are related to the other systems by a function \(f\):
\[(u_i, v_j) = f(x_i, y_j) + e_j = f[P(\phi, \lambda)] + e_j\]

where \(e_j\) is a random error associated with the \(i\)-th location. As discussed in the companion article, NotAQuad uses a 1st or 2nd degree polynomial for \(f\) derived from the GCPs. In particular, a function is chosen to minimize the root-mean-square prediction error:

\[
RMSE = \sqrt{\frac{1}{n} \sum_{i=1}^{n} e_i^2} = \sqrt{\frac{1}{n} \sum_{i=1}^{n} [(\hat{u}_i - u_i)^2 - (\hat{v}_i - v_i)^2]} / n
\]

where \(n\) is the number of GCPs and \((\hat{u}_i, \hat{v}_i)\) is a location predicted by \(f\). In other words, we find a function that puts predicted image locations as close as possible in a root-mean-square sense to the defined GCP locations. The program reports individual errors \(e_i\) as well as \(RMSE\). The latter is a measure of average distance error in pixels for a model fitted to all GCPs. It is often taken as a measure of georeferencing success.

NotAQuad also computes cross-validation (CV) errors as an alternative indicator showing how well the model predicts an unobserved value. CV errors are found by fitting a model with a single GCP omitted. The resulting error for the omitted location is noted, and the process repeats with another excluded GCP until all \(n\) CV errors have been computed. Because each model is fit without seeing an observation, individual CV errors are often considered a better measure of how well the model does for locations between the GCPs. Because of their sensitivity to inconsistent observations, CV errors are also very useful for pinpointing a misplaced GCP.

Clearly, if the goal is to reproduce a published map, one should choose \(P\) to agree with the true map projection. However, assuming model errors are acceptably small, output images are not harmed if the projection is not correct. The image will have the projection used (\(P\)) and will be labeled accordingly. GIS software will find correct projected and geographic coordinates. Similarly, text output for the GCPs will be correct. That said, if \(P\) is wrong, output images will different than what the cartographer intended. For example, a map drawn as a polyconic could become a conic or even a UTM.

**2. Installation**

NotAQuad is provided as Windows™ binary that can be executed from any directory. There is no install procedure to run nor are any registry changes required. The “installation” consists of copying the distribution package to any directory. As with any application, users can create desktop or program menu shortcuts pointing to the executable file. The program requires the Microsoft .NET framework version 4 or higher.

Quad-G+ uses the GDAL raster package and related software. All dependencies are distributed with Quad-G+ in a subfolder, so GDAL itself need not be resident. Changes to the system environment persist only while the program is running.

**3. Screen Layout**

**3.1 Main Screen**
Figure 2 shows the screen configuration during a typical georeferencing session. In this case 11 GCPs have been created, one of which is highlighted in all three panels as the so-called “active mark” ready for possible modification. Clicking on a panel changes the program focus to that panel. You can also use the Esc key to move between panels. Each panel has a distinct purpose:

**Navigation Panel** This is a low-resolution view of the map that can be panned and zoomed to focus on map sub-areas. As discussed below, this panel is used to create new GCPs. Clicking on a GCP makes that the active mark. Tabbing jumps to the next GCP. The Del key deletes the active GCP.

**Active Mark Panel** This displays a small area surrounding the active GCP at full image resolution. The green rectangle shows the mark search area as described below. The mark itself is also drawn at the current location. This is either the position returned by pattern matching or a position set by dragging the mark or using the keyboard arrow keys. Note that the mark is drawn using the current map projection. The Tab key advances to the next GCP.

**GCP Panel** GCP data appears in table form, including geographic and image coordinates as well as the associated model error with shading to indicate severity. The mark type and lon/lat values can be entered here. Within the table, the right-mouse button is used to delete marks. Clicking on a table heading will sort GCPs using the corresponding values in that column. Along the bottom of panel are buttons for various program operations described in later sections.

Figure 2. Main program screen with panels labeled for clarity. The navigation panel has focus, as indicated by the blue background. The GCP in the lower-left corner of the map is the active mark.

3.2 Other Panels

3.2.1 Map Information Panel
As seen in Figure 2, the navigation panel is accessed by the “Map View” tab. Other panels are exposed by clicking on their tab. For example, the “Map Information” tab is used to specify the datum, map projection and other data pertaining to the map. It appears as so:

![Map Information panel](image)

Figure 3. The Map Information panel.

As seen above, the map projection can be specified by entering a valid EPSG number, or a Proj4 text string, or by picking by name from a list of named projections (23 in total). Depending on the projection selected, different map parameters are enabled for editing. Parameter names loosely correspond to Proj4 conventions:

- **lon_0** Central meridian, negative value for west longitude
- **lat_0** Latitude of natural origin, negative value for southern hemisphere
- **lat_1** First (and possibly only) standard parallel, negative value for southern hemisphere
- **lat_2** Second standard parallel, negative value for southern hemisphere
**UTM zone** An integer zone number, negative for southern hemisphere zones

Users must always choose the underlying geographic coordinate system (i.e., the datum). More than 400 different datums are supported. These are listed by their EPSG number and common name. When a parameter is changed the “Apply Parameters” button is enabled. After clicking, parameter values are checked for validity.

Note there is a “Leave Undefined” radio button in Figure 3. Clicking exposes the following dialog:

![Supported Projections](image)

Figure 4. Projection Candidates dialog.

This form is used to choose projections for evaluation. After the dialog closes all projection parameters appropriate for the various candidates are enabled. NotAQuad fits georeferencing models for all candidates and reports prediction errors for each (see the model fitting section below).

The section in Figure 3 labeled “Control Mark Layout” contains information about GCPs. Although not strictly required, GCPs normally lie on intersections of a regular grid in lon/lat. For example, a graticule might have lines every 20° in longitude and latitude. If so, the “Gridded” radio button should be
checked. Alternatively, a user who intends to create arbitrary GCPs having nothing to do with a graticule should check “No Grid”. The rounding value is useful because graticule grids nearly always consist of so-called “nice” numbers. When NotAQuad predicts a lon/lat value, it rounds results according to the value provided.

3.2.2 Preferences Panel

Another tab exposes program preference settings:

![Figure 5. Program Preferences](image)

Please note that text boxes in the “Active Mark Panel” group contain lengths pertaining to the map, not Earth distances. They can be given in pixels, inches or mm, such as “2 mm” or “.1 in”. If no units are given the value is assumed to be in pixels. Meanings are as follows:

**Display Window Size** A region of this size width and height is extracted from the image scan.
**Search Radius** The program searches for the mark in an area centered on the current GCP location. The area searched is a square whose width and height are twice the search radius.

**Mark Tick Length** The search template for a mark is comprised of 2, 3, or 4 ticks, each with length equal to this value.

**Mark Color** Click to change the mark template’s color.

Model errors shown in the spreadsheet are shaded in colors based on their magnitude. Both threshold values and colors can be changed. The CV checkbox toggles between display of full-model errors and cross-validation errors.

Longitude and latitude values can always be entered as decimal degrees or degrees-minutes-seconds. The preference checkbox affects only their display in the GCP table.

*3.2.3 Help Panel*
The Help tab show various keystrokes and other controls. As seen in Figure 6 below, the operations available depend on which panel has program focus:

4. Program Use

4.1 Opening a Scan File

Use File→Open Image to import an image scan into NotAQquad. The program can use any raster format supported by GDAL. Images with more than about 10K pixels in either direction typically cannot be effectively handled at full resolution in the navigation panel. Thus NotAQquad prompts for permission to create smaller a thumbnail version when a scan is opened. We recommend accepting this, especially for very large scans. Navigation images are stored indefinitely as TiFF files in a Windows temporary directory and are re-used in subsequent sessions whenever possible. Please note that thumbnails are used only for display purposes in the navigation window. All other processing occurs at full image resolution.
4.2 Creating GCPs

4.2.1 Manual Entry

From the Navigation Panel, click to enter input mode and then click within the map near a graticule intersection (or near the desired GCP location). If two or more GCPs exist, the new point’s lon/lat values will be calculated. Otherwise lon/lat values can be entered in the GCP table. Use negative values for west longitude and southern hemisphere locations. If the mark is not an interior point, click on in the GCP table and pick one of the other mark types or choose “None” if the GCP is not a graticule intersection. Here for example, is a mark for the southern graticule boundary (drawn in pink):

![Image of GCP creation process]

Figure 7.

The descending tick is absent, as would be expected. The shape of the GCP template is correct because the pixels were computed based on the projection. However, the GCP is not positioned correctly. This can be corrected by clicking on one of the pattern search buttons:
Alternatively, you can click on the “Active Mark” panel and adjust the location as described above. This is the only option the “None” mark type—the program will not search for a “None” mark type.

4.2.2 Reading GCPs

NotAQuad can read CCPs that have been saved in CSV format. Use File→Open Control Points to read the file. NotAQuad will look for columns labeled “longitude” and “latitude” (not case sensitive) to acquire \((\phi, \lambda)\) values. If longitude isn’t found the program will look for “lon” in the header. If latitude isn’t found it will look for “lat” in the header. The program reports an error unless both longitude and latitude fields are present. Within the file, values of \((\phi, \lambda)\) can be given in decimal degrees or as DMS. Use one or more spaces between the DMS components (e.g., 130 15 10).

If the GCP file was saved by NotAQuad in a previous session, the program will find projection information and \((u, v)\) coordinates in the CSV file along with \((\phi, \lambda)\).

4.2.3 Using the “Make Grid” Facility

As mentioned above, new GCPs are created by the “Make Grid” button. The button is active if there are at least 4 GCPs. Clicking on the button spawns a new dialog:

![Add Grid Points dialog](image)

Figure 7. Make Grid example.

This example creates a 4x3 array of GCPs every 20° and 10° in longitude and latitude respectively. Grid increments can be set at values ranging from 1 minute to 30°. If any grid location duplicates an existing GCP, the existing point is retained and a duplicate point is not created.

4.3 Model Fitting

A new transform \(f\) is constructed whenever the Fit Model button is clicked. The current projection is used for all unless “Leave Undefined” is active. In that case models using all the candidate projections are fit and results are displayed in a sorted list like so:
In this example, the user would probably choose the polyconic for $P$ before making output files. Please note that $f$ is updated automatically when any $(\phi, \lambda)$ or $(\mu, \nu)$ changes, or when any projection parameter changes (including the datum).

The models discussed here are distinct from local models used to compute lon/lat and image coordinates (sections 1.1 and 1.2). Those models come and go as needed and are never exposed to the user.

4.4 Generating Output Files

NotAQuad will generate output images for either the entire scan or for a subarea selected by the user. Subareas are useful for maps that occupy a small part of a scanned image. To define a subarea, click on the navigation panel and drag in the usual manner to create a rectangle. After defining an area or accepting the default full image, use File-->Create Output Files. This leads to the following dialog:
This example creates two output images. The “Raw scan” is nothing more than the original raster image with GCP information placed in the header. No pixels are modified and the output image will look exactly like the input image unless the output file is opened with GIS software. However, a GIS program will recognize the GCPs and will show pixels in their projected locations and display coordinates using the output spatial reference system.

In contrast to raw images, the second option (not selected above) results in an image whose pixels are squares in the projected coordinate system. Any rotation in the original scan will be removed, and the horizontal and vertical image axes \((u, v)\) will correspond to \(x\) and \(y\) respectively. In other words, the image will be oriented in the standard north-up way. Obviously, the image size will change and the
raster will contain new pixels. Pixel colors will be related to those in the scan as determined by the color interpolation model selected.

A third option (selected in this example) likewise creates a projected (warped) output image. However, the map is rotated by an amount detected in processing the scan. This example comes from the map shown in Figure 2, which was printed with latitude increasing from the lower left to upper right corner. If the goal is to georeference the map and reproduce the atlas page, we want that rotation angle to be preserved. This option does that. Non-GIS software will display the map in its rotated orientation. However, because the geotransform is embedded in the file, GIS software will display the image in the usual north-up way. In other words, it will warp the saved image to a new orientation and display accordingly.

Output image compression options are as shown, and there is also an option for adding low-resolution overviews (pyramids) in the output image. In all cases if a subarea was defined, only that region will appear in the output image.

It should be mentioned that NotAQuad checks the georeferencing transform for reliability outside of the GCP envelop. In those areas there is obviously no control over the behavior of $f$ and wild oscillations are possible. The program looks for places where $f$ folds back on itself and warns the user if any such fold intersects the output raster.

4.5 Other Functions

Other functionality is accessed from File Menu. File→Open prj/wkt is used to input a projection and datum from an external text file. As implied by the menu title, the projection can be specified in either a Proj4 or WKT format. NotAQuad examines the file contents to detect the projection format; the file extension is not used.

The File→Save Control Points stores all defined GCPs in an external file named by the user. The GCP file contains the projection and datum in force as well as lon/lat and image coordinates for each GCP. Assuming a model has been fit, predicted coordinates and errors are also saved.